GP2

Nouveautés de GP2
INFORMATION IMPORTANTE :

A ce jour, aucune perte de données n'a eu lieu, suite à mon intervention du moins.
Si vous avez un problème, contactez-moi, c'est gratuit !
Je rappelle que je développe pour le fun, à défaut d'aller pécher ou faire du modélisme...
Et suis parfaitement identifiable, en France,
...téléphone, adresse, etc. Google est votre ami (hmmm !!!)
HAEFFELE Christian - 232 avenue du Levant - 30310 VERGEZE

Version de l'exécutable : 2.07i 08 mai 2024
- Fenêtre Ecriture / Ecriture par compte
- Ajout d'un bouton "Créer retour" permettant de créer d'un clic une écriture lié en crédit lorsque l'ont retourne un article commandé sur le net par exemple.

Version de l'exécutable : 2.07h 09 octobre 2023
- Générale :
- Corrections mineures + ajout d'un traitement personnalisé (Outils, Traitements sur les fichiers).
- Fenêtre Ecriture / Ecriture par compte
- Ajout de la colonne "Garantie" dans la table des écritures.
- Fenêtre Ecriture par compte
- Simplification du fonctionnement de l'affichage à une date choisie des soldes.
- Fenêtre Ecriture périodique
- Correction de la création automatique des nouvelles écritures, la Date sur compte pouvait être erronée sur certaines écritures.

Version de l'exécutable : 2.07g 26 juillet 2023
- Générale :
- Corrections mineures + ajout d'un traitement personnalisé (Outils, Traitements sur les fichiers).
- Fenêtre Ecriture / Ecriture par compte
- Activation de la touche F5 pour rafraîchir la liste affichée
- Ajout d'un champ Date de fin de garantie
- Fenêtre Ecriture périodique
- Ajout de la colonne Date sur compte.

Version de l'exécutable : 2.07e 03 mars 2023
- Générale :
- Corrections mineures + ajout d'un traitement personnalisé (Outils, Traitements sur les fichiers).
- Gestion des pièces comptable (facturation):
- Diverses corrections mineures.
- Correction état avec talon
- Fenêtre Ecriture / Ecriture par compte
- Correction du rafraichissement automatique qui pouvait se répéter x fois selon le champ en cours et le scroll de la roulette de la souris.
- Correction de l'enregistrement des écritures créées manuellement.
- Fenêtre Ecriture périodique
- Diverses corrections mineures.

Version de l'exécutable : 2.07d 11 février 2022
- Générale :
- Corrections mineures + ajout d'un traitement personnalisé (Outils, Traitements sur les fichiers).
- Gestion des écritures par compte :
- Marquer un compte directement dans la liste provoquait une erreur.

Version de l'exécutable : 2.07c 03 février 2022
- Générale :
- Les élements marqués sont surligné en jaune dans les listes.
- Gestion des écritures / écritures par compte :
- En mode parcours le champ "Date en banque" prenait la date du jour en cliquant dans le champ (mais ne s'enregistrait pas, ce qui pouvait induire en erreur).
- Le texte de commentaire des liens entre écritures généré automatiquement a été revu/corrigé.
Fenêtre Astuces :
- La fermeture de la fenêtre des Astuces pouvait provoquer un blocage.
- Fenêtre Tiers:
- La liste des types de réglements n'affichait pas tous les items.
- La liste des tickets ne ne s'affichait pas en totalité.

Version de l'exécutable : 2.07b 05 janvier 2021
- Nouvel utilisateur :
- La saisie du code postal ou de la ville provoquait un blocage. Refonte complète de cette fonction.
- Correction d'un bug lors de la saisie du RIB
- Ajout de ventilations et tiers en exemple

Version de l'exécutable : 2.07a 04 janvier 2021
- Facturation :
- Implémentation d'une gestion de stock au niveau des articles. La saisie des stocks peut se faire "en cascade" directement dans la table (liste des articles).
Ils sont décompté en "Prévu" à la saisie d'une commande, et en "Réel" lors de la saisie d'une facture.
- Blocage aléatoire de GP2 :
- Désactivation de la gestion des fonds grisé pour les fenêtres inaccessibles, qui selon les configuration matériels des pc provoque des blocage aléatoire "access violation (GPF)".
- Gestion des Ecritures :
- A la suppression d'écriture, il est possible de supprimer en cascade toutes les écritures marquées. A utiliser avec prudence !

Version de l'exécutable : 2.06z 14 octobre 2020
- Gestion des tickets immobilier :
- Blocage à l'ajout d'un nouveau ticket dû à un champ de saisi mal nommé dans le code.
- Facturation :
- Modifications diverses sur l'édition des factures.

Version de l'exécutable : 2.06y 09 octobre 2020
- Virements :
- Poser puis enlever une date "sur compte" pouvait provoquer une erreur d'enregistrement.

Version de l'exécutable : 2.06x 08 octobre 2020
- Gestion des tickets :
- A l'ajout d'un nouveau ticket le libellé ne se mettait pas à jour.
- Dans certains cas les tickets dédiés à l'immobilier n'était pas affiché.
- Gestion des virements :
- Selon une manipulation bien précise il pouvait arriver que l'enregistrement d'une des écritures de virement était erronée, erreur qui se corrigeait par un simple modification / validation mais pouvait prêter à confusion.
- Gestion des écritures / écritures par compte :
- Correction de l'ouverture de la fenêtre de sélection d'écriture lié qui pouvait selon les manipulations précédentes afficher la totalité des écritures sans tenir compte des filtres posés.
- Facturation :
- Dans les options ont peut désactiver la gestion de la tva pour les auto-entrepreneurs et autre non soumis.
- Gestion des tiers :
- Le filtre par Marques ne fonctionnait pas.
- L'inversion des coches porovoquait un plantage de GP2
- Sauvegarde :
- A la fermeture de GP2 la fenêtre de sauvegarde peu rester ouverte en fin de sauvegarde en cochant la case "Ne pas quitter...".

Version de l'exécutable : 2.06w 20 juillet 2020
- Gestion des tickets - Immobilier :
- Diverses évolutions orientés métier.

Version de l'exécutable : 2.06v 04 juin 2020
- Gestion des tickets - Immobilier :
- Diverses évolutions orientés métier.

Version de l'exécutable : 2.06t 09 avril 2020
- Gestion des écritures par compte :
- Déplacement du champ "Lettrage" (permet de distinguer x écritures par exemple pour facture Amatruc (chut, pas de pub) découpé en quatre) en mettant la même lettre sur les écritures ont pourra facilement les repérer lors du paiement.
- Gestion des tickets :
- Dans la gestion des utilisateurs, la combo Métier permet d'adapter la fenêtre de gestion des tickets au métier sélectionné.

Version de l'exécutable : 2.06s 06 avril 2020
- Gestion des écritures par compte :
- Possibilité de saisir une date d'arrêt des comptes; pour éviter les erreurs le fond passe en rouge.
- Gestion des factures :
- Corrections minimes diverses sur les éditions de factures.
- Contrôle des TAF :
- Un effet "papillon" (merci Jacques :-D ) du à une fréquence de contôle des Trucs A Faire trop élevé.

Version de l'exécutable : 2.06r 02 avril 2020
- Gestion des factures :
- Selon la méthode de saisie, le libellé de l'édition pouvait rester bloqué sur "FACTURE".
- Gestion des tickets :
- Le champ de saisi d'un ticket était involontairement bloqué à 1 ligne.

Version de l'exécutable : 2.06q 18 février 2020
- Gestion des tickets :
- Diverses corrections mineures, ajout de fonctionnalité propre à mon activité :-) .

Version de l'exécutable : 2.06p 21 janvier 2020
- Gestion des tickets / Trucs à Faire:
- Diverses corrections mineures, ajout de la fonctionnalité SMS, ajout d'un champ image.

Version de l'exécutable : 2.06o 19 janvier 2020
- Gestion des tickets / Trucs à Faire:
- Diverses corrections mineures

Version de l'exécutable : 2.06n 16 janvier 2020
- Gestion des tickets :
- Il est possible d'envoyer directement un sms d'un clic. NB : me contacter si cette fonction vous intéresse; c'est environ 10 € les 100 sms (même pas pour moi !!).
- Sauvegarde :
- Si l'option sauvegarde automatique en fin de session est activé, il pouvait arriver dans certains cas de ne plus pouvoir quitter "proprement" GP2.
- Import GP V1:
- Un renommage malheureux du nom d'une rubrique a posé problème à l'importation.

Version de l'exécutable : 2.06m 08 janvier 2020
- Gestion des tickets :
- Diverses évolutions concernant la gestion des tickets.

Version de l'exécutable : 2.06l 25 décembre 2019

Contrôle de la procédure sauvegarde / restauration
...sur demande (fondée !!!) de Claude M. ;-)

INFORMATIONS IMPORTANTES

- La sauvegarde génère un fichier au format ZIP, et peut être décompresser sans utiliser GP2.
- GP2 ne se sauvegarde pas lui-même ! Il suffit de le réinstaller pour réutiliser vos fichiers.
- Les fichiers GP2 sont cryptés, en aucun cas je ne donne le moyen d'y accéder, vos données sont confidentiels, et je n'ai aucun moyen de controler votre identité !
- En cas de problèmes, je peux vous demander de m'envoyer tel ou tel fichier pour tentative de réparation, souvent dû à un changement de version de GP2 (ce qui entraîne que l'on ne peut plus y accéder)

- Sauvegarde / Restauration :
- Ajout du chemin lorsqu'on sauvegarde sur clé USB.
- Contrôle de la procédure, tests, corrections...

Version de l'exécutable : 2.06k 18 décembre 2019
- Création de virements > Corrections bug :
- Lors de la saisie de deux (ou plus) virements d'affilés, si le premier avait une date de banque saisie, l'enregistrement du second, s'il n'avait pas de date de banque, était érroné et provoquait des erreurs dans les comptes, erreur qui se corrigeait "toute seule" par simple accès à l'écriture concerné.
- Gestion des écritures périodiques :
- DEFI DU JOUR : Qui arrivera à reproduire l'anomalie d'affichage signalé par Jean-Marie R. ?
Date de création le 05/12/2019 > affiché : Dimanche 31 Janvier 2100
- Import de fichiers > implémentation de l'import de fichier CSV du Crédit Agricole :
- Le compte, tiers, ventilation et type de paiement n'étant pas identifiable, une valeur par défaut (pouvant être modifié avant l'import définitif) est renseigné.
- Sauvegarde / restauration :
- Les diverses évolutions de GP2 ont eu raison du bon fonctionnement de la procédure de restauration. Aucune perte de données, les fichiers étant intégralement compressé au format ZIP, seul la décompression et réindexation via le logiciel posait problème.

Version de l'exécutable : 2.06j 28 novembre 2019
- Corrections des fichiers :
- Modifications apportées à la structure des fichiers.

Version de l'exécutable : 2.06i 24 novembre 2019
- Gestion des Tickets / TAF :
- Diverses modifications / améliorations, stabilisation gloables des interactions.

Version de l'exécutable : 2.06h 09 novembre 2019
- Gestion des écritures / Ecritures par compte :
- Correction : Lors de la duplication d'une écriture tous les champs de saisie n'étaient pas initialisés.
- Gestion des Tickets :
- Diverses modifications / améliorations.

Version de l'exécutable : 2.06g 04 novembre 2019
- Gestion des écritures Périodiques :
- Correction : Dans certaines circonstances l'affichage textuelle de/des dates de l'opération à venir pouvait provoquer une erreur blocante.
- Gestion des Tickets :
- Liaisons entre les Tickets, Actions et TAF.

Version de l'exécutable : 2.06f 27 octobre 2019
- Tickets :
- Ajout de champs de saisie (utile à mézigues). :-)
- Gestion des tiers :
- Afin d'optimiser l'affichage, les cumuls ne sont plus affichés en direct.
- Possibilité d'afficher les cumuls entre 2 dates.
- Ecran d'accueil :
- En haut à gauche un clic sur le titre de la gestion en cours ramène à l'accueil.

Version de l'exécutable : 2.06d 26 octobre 2019
- Nouvelle gestion : les Tickets :
- Les tickets permettent d'enregistrer des échanges afin d'avoir un historique sur un sujet.
Exemple; vous m'appelez pour un souci avec GP2 (j'ouvre un Ticket), on se rappel plusieurs fois à ce sujet (je créer des Actions au sein de ce ticket), quand tout est réglé le cloture le ticket.
- Gestion des Tâches (TAF) :
- Evolution de la saisie des tâches selon les diverses demandes reçus, possibilité de les lier à des Ticket ou des Actions.
- Gestion des écritures périodiques :
- Corrections diverses concernant les écritures multiples.
- A la demande générale,
activation de l'aide... qui n'est autre que ce présent document !

Version de l'exécutable : 2.06c 14 octobre 2019
- Accueil :
- Restauration du bouton "Tâches à faire" (TAF, ...ou Trucs à faire !).
- Gestion des Tâches :
- Evolution de la saisie des tâches selon les diverses demandes reçus.

Version de l'exécutable : 2.06b 06 octobre 2019
- Gestion des répartitions :
- Correction d'une anomalie d'affichage (dans certaines circonstances la hiérarchie affichée était érronée).
- Accueil :
- Suppression du bouton "Tâches à faire" (TAF, ...ou Trucs à faire !), qui sera remplacé par une autre gestion. Si vous l'utilisiez, merci de m'en faire part.

Version de l'exécutable : 2.06a 07 mai 2019
- Edition des Factures :
- Correction de diverses anomalies d'éditions.

Version de l'exécutable : 2.05z 11 avril 2019
- Gestion des Ecritures Périodique :
- La case à cocher "Date sur compte identique" était désactivée. Corrigé.
- Gestion des Factures :
- Problème d'affichage; Corrigé.

Version de l'exécutable : 2.05y 08 avril 2019
- Gestion des Ecritures / Ecritures par comptes :
- Ajout d'un champ "Lettrage" (1 à 5 caractères) permettant relier des écritures.
- Correction du changement d'état des boutons "Rafraichir" et "Rapprochement" selon l'onglet en cours.

Version de l'exécutable : 2.05x 27 mars 2019
- Gestion des Ecritures / Ecritures par comptes :
- Modification du texte automatique lors de l'ajout d'une liaison entre écritures.
- Ajout d'une case à cocher "Liaisons validées". Cochez cette case lorsque, par exemple, pour une dépense de santé (médecins, ...), vous avez liés toutes les écritutres de remboursement des écritures de santé (CPAM, Mutuelle, ...).
- Virements :
- La saisie manuelle d'un tiers inexistant provoquait un blocage. Corrigé.

Version de l'exécutable : 2.05w 21 mars 2019
- Gestion des Ecritures par comptes :
- Selon l'utilisation, il pouvait arriver qu'une écriture ne s'affichait pas. Corrigé.
- L'indicateur "Ecritures liés" pouvait ne pas se sélectionner; corrigé.
- Grands-livres :
- Le double-clic sur une ligne ouvre l'écriture sélectionné.
- Générale :
- Correction de l'interface des champs Code Postal et Ville.

Version de l'exécutable : 2.05t 10 mars 2019
- Gestion des comptes :
- Corrections mineures d'ergonomie
- Virements :
- Corrections mineures d'anomalies d'enregistrement des liaisons entre les écritures
- Gestion des Ecritures / Ecritures par comptes :
- Ajout d'un cumul sur la liste des liaisons (par exemple lors d'une dépense de santé, permet d'avoir le total des écritures de remboursement de la CPAM, de la mutuelle, ...)
- Contrôle de date futur rectifié pour n'avoir plus qu'un seul message (sortie de champ ou validation).
- Lors de la duplication d'une écriture créée par virement le lien du virement était conservé. Corrigé.
- Gestion des factures :
- Correction de l'état d'aide à la déclaration de TVA.
- Correction mineure d'affichage
- Blocage du retour systématique sur la liste à la validation d'une pièce comptable
- Gestion des paramètres / factures :
- Ajout de 2 modèles de Conditions Générales de Vente

Version de l'exécutable : 2.05s 12 février 2019
- Gestion des comptes :
- Correction d'un bug survenant dans des conditions bien précises lors de la saisie du RIB.
- Gestion des factures :
- Correction de l'état d'aide à la déclaration de TVA.

Version de l'exécutable : 2.05p 02 septembre 2018
- Edition des Ecritures :
- Explications pour les avertis : Un renommage de rubrique du fichier Tiers n'a pas été repris dans la requête de la liste des écritures pour l'impression. Corrigé.

Version de l'exécutable : 2.05o 11 février 2018
- Gestion des véhicules :
- Nouvelle gestion en cours de développement.

Version de l'exécutable : 2.05n 06 février 2018
- Gestion des écritures périodiques :
- Correction d'un bug découlant d'une mise à jour de l'outil de développement.

Version de l'exécutable : 2.05m 31 janvier 2018
- Correction d'un bug bloquant à la première installation au premier lancement
- tout est dit !

Version de l'exécutable : 2.05l 28 septembre 2017
- Correction de la navigation à l'écran par la touche TAB :
- Plusieurs fenêtre ont été revues, n'hésitez pas à me signaler les défauts de navigation et/ou d'ergonomie !
- Ajout de la gestion villes (cf. section Réglages) :
- Avec les regroupements des communes, il est maintenant possible de créer une nouvelle commune.
- Amélioration du premier lancement Gestion Privée v2 :
- Gestion des communes facilité lors du premier accès au logiciel via l'assistant de création de dossier.

Version de l'exécutable : 2.05j 22 septembre 2017
- Correction importation des anciennes versions :
- Le fichier des tiers est scindé afin de pouvoir enregistrer plusieurs interlocuteurs. De ce fait, l'importation bloquait. problème résolu !

Version de l'exécutable : 2.05i 17 août 2017
- Correction installation :
- Le fichier des villes était défaillant. Corrigé.

Version de l'exécutable : 2.05h 16 août 2017
- Gestion des comptes, Ecritures par compte :
- Changement de libellé du bouton "Saisie rapide" qui devient "Rapprochement".
- Correction installation :
- Les fichiers de bases dans certains cas ne s'installaient ...(grrrr) toujours pas !

Version de l'exécutable : 2.05g 27 juillet 2017
- Gestion des comptes, Ecritures par compte :
- Changement de libellé du bouton "Saisie rapide" qui devient "Lettrage".
- Correction installation :
- Les fichiers de bases dans certains cas ne s'installaient ...toujours pas !

Version de l'exécutable : 2.05f 22 juillet 2017
- Gestion des comptes, Ecritures par compte :
- Ajout d'un bouton ouvrant directement le site du compte sélectionné.
- Correction installation :
- Les fichiers de bases dans certains cas ne s'installaient pas.

Version de l'exécutable : 2.05c 17 mai 2017
- Gestion des TAF (Trucs à Faire) :
- Pour ne plus rien oublier !

- Ecritures périodiques :
- Corrections du libellé qui ne se mettait pas à jour lors de changements de date.

Version de l'exécutable : 2.05b 15 février 2017
- Générales :
- Corrections de bug bloquant au premier lancement de GP2.

Version de l'exécutable : 2.05a 12 février 2017
- Générales :
- Evolution / stabilisation / optimisation de divers traitements.
- Automatisation des plages de dates
- Activation de la licence d'utilisation du module de facturation

Version de l'exécutable : 2.04n 12 janvier 2017
- Import GP1 :
- Adaptation de l'import suite aux nombreuses modifications de GP2.

Version de l'exécutable : 2.04m 11 janvier 2017
- Si les dates de périodes ne sont pas mémorisés (cf. options Utilisateurs), la plage de date d'affichage s'étend automatiquement de l'écriture la plus ancienne non pointé à la plus future (euh, ça se dit ça ?). Ainsi, plus d'écritures "perdues" car masquées par la période affichée.

- Diverses corrections minimes

- Fenêtre Ecritures - Ecritures par compte :
- Optimisation de l'affichage.

Version de l'exécutable : 2.04l 20 décembre 2016
- Suppression du message au premier démarrage après mise à jour.
- Diverses corrections minimes

- Fenêtre Ecritures - Ecritures par compte :
- Ajout d'une édition permettant d'imprimer la liste des écritures. Via la fenêtre Ecriture par compte, possibilité de filtrer à l'impression par compte.

Version de l'exécutable : 2.04k 19 décembre 2016
- Ecritures périodiques : ...euh, et autres !
- Bugs bloquants... Corrigés.

Si vous êtes complètement bloqué, à défaut d'aller voir un kiné, n'hésitez pas à me faire un sms (06 62 10 25 30). Plus tôt je suis informé, plus rapidement je peux apporter les corrections nécessaires. Là, pour le coup, j'ai besoin de vacances !

Pas pour me faire pardonner, mais pour expliquer le truc...
Juste pour comprendre : lorsque j'ajoute dans le logiciel un champ de saisi
(exemple "Second prénom"), il est ajouté dans le fichier "Tiers".
Avant une mise à jour, il est fortement recommandé de faire une sauvegarde. Pourquoi ? car en cas de panne "matériel", les fichiers peuvent devenir totalement inexploitable. Là, c'est perte irrémédiable des données.
Ok. On passe la mise à jour. Les fichiers sont adaptés, et donc dans mon exemple le "Second prénom" est ajouté au fichier "Tiers". Pas de bol, les joies de l'informatique s'en mèlent, rien ne va plus. C'est là que ça se complique pour les novices...
Le programme téléchargé est en version y, les fichiers sauvegardé en version x...
Là, à moins de bien maitriser le truc (restaurer au bon endroit la sauvegarde, recopier le bon GP2.exe, recréer un dossier bidon, remplacer par les anciennes données, retenter la mise à jour, etc.), faites un sms à bibi (06 62 10 25 30) et je vous dépanne (si si, c'est gratuit !). Même si quelques comiques me paient en liquide... si si, en vrai liquide ! (hein JL ?) Cela dit, c'est vrai que c'est sympa. Ca me fait de nouveaux copains... lol

Version de l'exécutable : 2.04i 14 décembre 2016
- Ecritures périodiques :
- Bugs bloquants... Corrigés.
Merci à tous pour votre compréhension !

Version de l'exécutable : 2.04g 11 décembre 2016
- Type de règlement : Plusieurs chéquiers ?
- Les types de règlements peuvent maintenant être rattaché (ou pas !) à un compte bancaire. Lors de la création d'une écriture, dans la liste déroulante (combo pour les puristes) seront affichés uniquement les types de règlements du compte en cours ainsi que tous les types de règlements non rattachés à un compte.
- Période :
- Dans la section Réglages, menu Gestion des paramètres, Utilisateur, onglet Préférence :
Nouvelle option; Mémoriser mes dates de périodes.
Toutefois, la date de début de période est automatiquement affecté à la date de la plus ancienne écriture non pointée.
- Type de compte :
- A le demande générale et sous votre tonnerre d'applaudissements :-) les comptes peuvent dorénavant être de type "Courant", "Epargne" ou "Autre".

- à venir :
- Facturation : création automatique des écritures, règlements multiples, flag Soldé.

Version de l'exécutable : 2.04f 05 décembre 2016
- Fenêtre Ecritures - Ecritures par compte :
- Ajout du bouton permettant de modifier la liste des moyens de paiement (ajout de chéquier, ...).
- Correction d'un bug bloquant lors d'un ajout dans la fenêtre Ecritures.

Version de l'exécutable : 2.04e 03 décembre 2016
- Traitements spécifiques :
- Certaines situations nécessitent des corrections et ou traitement particulier, pouvant mettre en péril les données d'utilisateurs non confrontés à un problème précis.
A cette fin, dans la section Outils, un nouvel onglet permet d'accéder par code personnel au traitement voulu.
- Installation en réseau :
- Il est maintenant possible de n'avoir qu'un simple raccourcis vers GP2.exe sur chaque poste. Il suffit, dans les propriétés du raccourci, de mettre en ligne de commande un nom ou un numéro. Seuls les caractères alphanumérique sont autorisé.
Exemples de ligne de commande :
"\\MONSERVEUR\MaCompta\GP2\GP2.exe" /Direction
"\\MONSERVEUR\MaCompta\GP2\GP2.exe" /Secrétariat
va créer les fichiers Poste_cfg_Direction.FIC et Poste_cfg_Secretariat.FIC

Version de l'exécutable : 2.04b 24 novembre 2016
- Module Facturation :
- Consolidation du module de facturation.
- Import de fichiers Dolibarr

Version de l'exécutable : 2.03x 05 novembre 2016
- Fenêtre principale :
- Correction minime d'un bug qui empèchait l'affichage correct des anniversaires du jour.
- Module Facturation :
- Nombreuses, diverses et variés (sic !) évolution dans tout le module de facturation.
- Ajout d'un champ "Département" dans les articles, permettant de filtrer les articles selon le département du client (frais de port, d'intervention, ...)

Version de l'exécutable : 2.03w 03 octobre 2016
- Fenêtre sauvegarde :
- La sauvegarde sur clé usb quittait GP2 même si "Ne pas quitter..." était coché.
- Fenêtre Facturation / Train de facturation :
- Corrections diverses

Version de l'exécutable : 2.03v 08 septembre 2016
- Fenêtre Ecritures - Ecritures par compte :
- Correction de l'enregistrement du flag Lié.

Version de l'exécutable : 2.03t 07 septembre 2016
- Fenêtre Ecritures - Ecritures par compte :
- Possibilité de lier les écritures entre elles. Ex. Frais professionnels et remboursement,
ou frais médicaux et remboursement CPAM, mutuelle, etc.
- Correction de l'incrémentation automatique du numéro de chèque (le message ne s'affiche plus systématiquement lors de modification).
- Virement:
- Ajout de la liaison entre les deux écritures
- Les dates de virements pouvaient poser problème à la validation de l'opération.
- Corrections diverses minimes

Version de l'exécutable : 2.03s 26 juillet 2016
- Divers:
- Un fichier n'était pas pris en compte à la mise à jour. Recompilation complète.

Version de l'exécutable : 2.03p 23 juillet 2016
- Accueil:
- Suppression provisoire du champ météo (ce dernier étant trop souvent hors service), une autre solution sympa est recherché (vos suggestions sont les bienvenues comme toujours !).
- Sauvegarde:
- Dorénavant il est possible de faire une sauvegarde en fin de session sans quitter automatiquement GP.
- Possibilité de saisir directement une autre adresse mail du destinataire que celle saisi dans les réglages/paramètres.
- Virement:
- Correction d'une anomalie, les écritures générés automatiquement n'étaient pas filtré dans les écritures en cours.
- Fenêtre Ecritures - Ecritures par compte :
- Lors de la saisie de plusieurs écritures, le champ Numéro de chèque pouvait rester affiché alors qu'il n'était pas requis.
- Suppression en série:
- Correction d'une anomalie, lors de suppressions en série un décalage d'identifiant interne pouvait se produire.
- Fenêtre de gestion des Tiers :
- Plein de modifs, on peut maintenant avoir autant de numéro de téléphone mail ou fax qu'on veut. Chaque tiers peut être lié à un autre (pour créer des familles, les contacts et tiers sont maintenant dans la "même boite"). Enfin, chaque Tiers peut faire parti d'un groupe, Groupe qui pourront être sélectionner pour divers traitements; facturation, e-mailing, etc.

Version de l'exécutable : 2.03o 03 mai 2016
- Globale:
- Le fichier des Fournisseurs devient le fichier des Tiers. Ce fichier intègre également le fichier des contacts qui est automatiquement intégré lors de la mise à jour.

- Gestion des documents :
- Les liens vers un document non liés à une écriture ne s'affichaient pas. Corrigé.
- Ajout d'une date de document et d'une date de saisie.

Version de l'exécutable : 2.03n 02 mai 2016
- Globale:
- Problème de compilation, relance du processus de mise à jour.

- Fenêtre Ecritures - Ecritures par compte :
- Corrections de quelques ancrages de champs.

Version de l'exécutable : 2.03k 02 mai 2016
- Globale:
- Amélioration de l'affectation automatique des dates de périodes (du... au ...). Par défaut, la période va du 01/01/20xx au 31/12/20xx (sauf si une écriture plus ancienne n'est pas comptabilisé, auquel cas, pour éviter de la masquer, la date de début sera celle de la date de cette écriture).

- Fenêtre Facturation / Train de facturation :
- Derniers "réglages" avant mise en production. Réputé opérationnel à ce jour.

- Fenêtre Ecritures - Ecritures par compte :
- Modification de l'interface de saisie

- Fenêtre Ecritures périodique :
- Correction bug; dans certains cas le calcul de la prochaine date provoquait un blocage.
- Le contrôle de la ventilation selon le fournisseur était inversé (oui/non dans la fenêtre de dialogue)

Version de l'exécutable : 2.03j 22 avril 2016
- Globale:
- Le fichier des Fournisseurs devient le fichier des Tiers. Ce fichier intègre également le fichier des contacts qui est automatiquement intégré lors de la mise à jour.
- Suite à de trop nombreuses pressions d'utilisateurs (merci !), je cède.
Un bouton vous permet dorénavant de me faire un don ...

- Fenêtre Ecritures - Ecritures par compte :
- Dorénavant il est possible de lier entre elles les écritures. Un double-clic positionne automatiquement sur l'écriture lié. Utilité : par exemple retrouver plus facilement les écritures d'un remboursement sécu pour une dépense médical, ou un remboursement d'un achat, ou les écritures d'un paiement en plusieurs fois, ...

- Fenêtre Facturations
- Le module de facturation avance bien; pas encore totalement opérationnel mais permet déjà de s'exercer !

Version de l'exécutable : 2.03i 09 avril 2016
- Globale:
- modification du mode d'affichage des onglets (en test, quelques utilisateurs ayant des soucis d'affichages)
- correction visuel des tables contenu dans les listes déroulantes
- affichage d'un message moins terrorisant :-) pour les novices lors de blocage pendant
les suppressions.

- Fenêtre Ecriture périodique:
- Correction des dates des écritures périodiques concerné par l'année bissextile (29/02/2016)
- Gestion des champs selon le type d'écriture (unique, multiple ou permanente)
- Ajout des cumuls de colonne + calcul de la balance (cf. bulle de la table)

Version de l'exécutable : 2.03h 14 février 2016
- Renforcement du contrôle de la case à cocher "Pointé".

Version de l'exécutable : 2.03f 15 octobre 2015
- Renforcement des contrôles de cohérence lors de la création des écritures périodiques suite à un signalement suspect non reproductible.

Version de l'exécutable : 2.03e 06 octobre 2015
- Modification du contrôle de l'accès à internet.
- Fenêtre Ecriture périodique à créer : correction de la requête d'affichage; si le fournisseur d'une écriture périodique n'avait pas de ventilation par défaut, les écritures périodique de ce fournisseur n'apparaissaient pas.
-Fenêtre Ecritures et Ecritures par compte : Ajout de menu contextuel sur les champs date permettant lors du pointage de modifier la date par défaut (mise automatiquement en cochant la case), ou lors de la saisie dans l'onglet détail.
- Globale : corrections diverses mineures (taille de liste de combo, style, ...)

Version de l'exécutable : 2.03d 04 octobre 2015
- Général : lors de suppression, suivant le tri en cours le positionnement de la ligne sélectionné semblait aléatoire. Est sélectionné maintenant après suppression la ligne suivante.
- Fenêtre Fournisseur: à l'ouverture de la fenêtre le champ ville pouvait afficher une donnée erronée.
- Fenêtre Ecriture / Ecriture par compte: Lors d'une duplication la case à cocher Pris en compte n'était pas activé.
- Correction erreur de connexion aux fichiers.

Version de l'exécutable : 2.03c 29 septembre 2015
- Fenêtre Ecriture par compte: correction d'un traitement commun à tous le logiciel qui perturbait le fonctionnement de la récopie d'écriture.

Version de l'exécutable : 2.03b 29 septembre 2015
- Fenêtre Ecriture par compte: correction d'un traitement commun à tous le logiciel qui perturbait le fonctionnement de la récopie d'écriture.

Version de l'exécutable : 2.03a 29 septembre 2015
- Création des fichiers de base:
Ajout d'un Type de paiement "Remise de chèque" pour les encaissements (crédit) par chèque dans les fichiers de base.
- Petite refonte ergonomique de l'écran principal
- Gestion des documents :
Ajout de la colonne "Ecriture du"
Ajout du bouton de visualisation dans le menu contextuel de la table
- Fenêtre principale : corrections du champ "Anniversaire du jour" et de l'état lié.
- Fenêtre Ecriture : suppression de l'onglet Divers qui était vide.

- Gestion de la facturation
Première version, non validé.
Attention : à terme, ce module sera soumis à licence d'utilisation.

Version de l'exécutable : 2.02z 10 septembre 2015
- Fenêtres Ecritures / Ecritures par compte:
Dans les tables, correction du tri des colonnes Compte, Fournisseur, Ventilation et Type de paiement.
- Fenêtres de paramètrage:
- Bug bloquant sur la fenêtre de configuration du dossier lors du passage en mode Modification.
- Fenêtre Sauvegarde:
- En sauvegarde sur clé USB, possibilité d'ouvrir le dossier de sauvegarde en fin de traitement pour contrôle.

Version de l'exécutable : 2.02x 07 septembre 2015
- Fenêtres de paramètrage:
- Correction de l'interface.

- Fenêtre Ecritures périodique à créer :
Erreur d'affichage, la colonne Compte affichait les mêmes données que la colonne Fournisseur. Corrigé.

- Fenêtres Ecritures / Ecritures par compte:
Dans la table, le contrôle d'antériorité des dates ne se faisait pas.
Les champs n° chèque et/ou commentaire du moyen de paiement n'était pas remis à zéro lors du changement du mode de paiement.

Version de l'exécutable : 2.02w 15 août 2015
- Fenêtres Ecritures / Ecritures par compte:
- La saisie d'une date sur compte n'activait pas le flag "Pointé". Corrigé.
- Lors de la saisie d'un compte, fournisseur ou ventilation inexistant, retour
sur le champ en saisi lors du contrôle de validation. L'accès à la gestion
correspondante mémorise la valeur saisie, qui est reprise si on créer un
nouvel enregistrement. Si toi pas comprendre, ...essaie encore ! ;-)
- Contrôle de la ventilation pour le fournisseur en cours : le contrôle pouvait
être gènant à la saisie. Corrigé. Celui-ci ne se fait plus qu'en modification
d'une écriture existante.

- Fenêtre Sauvegarde:
- La case à cocher "Ne plus proposer..." n'était pas activé. Corrigé.

- Fenêtre Fusion:
- Il était possible de lancer le traitement sans que la destination soit renseigné. Corrigé.
- Pour les fournisseurs et les ventilations il est possible d'en créer sans quitter l'écran en cours.

Version de l'exécutable : 2.02v Vendredi 31 juillet 2015
- Fenêtre de sauvegarde:
- ajout d'une case à cocher permettant de désactiver l'automatisme.
- désactivation des messages de fermetures à la sauvegarde de sortie

Version de l'exécutable : 2.02u Lundi 6 juillet 2015
- Modification de l'écran d'accueil
- Gestion des écritures / écritures par compte :
Le tri est dorénavant mémorisé lors du rafraichissement des tables
- Incrémentation automatique du numéro de chèque; corrigé.

Version de l'exécutable : 2.02t Dimanche 31 Mai 2015
- Gestion des écritures : La coche "Pointé" ne se mettait pas toujours à jour lors de saisie de date sur compte en-dehors de la table.
- La coche "Pointé" n'était pas pris en compte dans les écritures périodiques.
- Message d'erreur "champ inconnu"

Version de l'exécutable : 2.02s Samedi 30 Mai 2015
- Gestion des écritures : L'action de la roulette de la souris après avoir filtré la liste des écritures par une des liste déroulantes entrainait un rafraichissement multiple. Corrigé.
- Correction de l'interface de l'onglet communication de la fenêtre des paramètres utilisateurs

Version de l'exécutable : 2.02r Vendredi 29 Mai 2015
- Gestion des écritures : ajout d'un filtre pour afficher que les écritures en cours, celles déjà pointés ou toutes.
- Correction : lors de la saisie rapide, défaut d'enregistrement du pointage. Corrigé.

Version de l'exécutable : 2.02q Jeudi 28 Mai 2015
- Correction de l'interface de saisie des écritures.
- Ajout d'une colonne de pointage rapide; en saisie rapide, un clic sur la case à cocher insère la date du logiciel (modifiable à l'ouverture du dossier) dans la colonne "Date sur compte". Si on décoche, la date en cours est supprimé.
- Modification du contrôle de la ventilation; ce contrôle se fait dorénavant en sortie de champ de la liste déroulante des fournisseurs.

Version de l'exécutable : 2.02p Vendredi 22 Mai 2015
- Signature numérique de l'exécutable.

Version de l'exécutable : 2.02o Dimanche 17 Mai 2015
- Correction de la fenêtre de connexion. Le nom du dossier n'est plus obligatoire dans le chemin d'accès aux données GP2.
- La sélection par défaut du premier champ en saisie provoquait un changement involontaire de l'onglet en cours. Corrigé.
- Correction des fenêtres Ecritures par compte et Compte; les cumuls tenait compte, selon le choix de l'utilisateur, des écritures dont la case "Pris en compte" était décoché, ce qui pouvait induire en erreur en affichant un montant total ne correspondant pas à la réalité.

Version de l'exécutable : 2.02n Jeudi 14 Mai 2015
- Ajout d'un indicateur sur la fenêtre de sauvegarde.
- Fenêtres écritures : changement de comportement: à la validation (ou annulation) retour sur l'onglet d'origine.
- Ajout d'un traitement de correction du fichier écritures pour "Jo" uniquement !!

Version de l'exécutable : 2.02m Mardi 05 Mai 2015
- Le contrôle de sauvegarde automatique en quittant GP2 était désactivé. Corrigé.
- Fenêtres écritures : correction du mode de saisie rapide afin de revenir dans la colonne "Date sur compte" à chaque changement de ligne pour éviter d'entré en saisie dans l'entête de la colonne trié.
- Correction de l'ordre de navigation dans les fenêtres de saisie d'écritures.

Version de l'exécutable : 2.02k Mardi 28 Avril 2015
- Formatage automatique (+xxx xx xx xx xx ou xx xx xx xx xx) des champs numéro de téléphone
- le autres points signalés arrivent !! patience...

Version de l'exécutable : 2.02j Mercredi 22 Avril 2015
- Ecritures périodiques : Correction de l'incrémentation automatique de la date lors du traitement.
- Ebauche du guide > évolution selon le retour fait par les premiers utilisateurs

Version de l'exécutable : 2.02i Lundi 20 Avril 2015
- Virements : dorénavant pour les écritures créer par la fenêtre Virement, lors de la suppression de l'une des deux il est proposé de supprimer également l'autre écriture.
- Correction de l'accès et de la fenêtre de restauration de données.
- Ebauche d'un mode "Guide" > en test.
- Ebauche du module de facturation > non opérationnel à ce jour !

Version de l'exécutable : 2.02g Jeudi 16 Avril 2015
- Réactivation de la fonction de coloration du champ en saisie (désactivé car soupcon de provoquer des blocages de l'appli)
- Lors de la nouvelle création d'un compte, fournisseur ou ventilation, ce nouvel enregistrement n'apparaissait pas immédiatement dans les autres fenêtres, et contraignait à quitté GP ! Corrigé.
- Correction de la taille des listes des combos.
- Certaines colonnes "technique" pouvait apparaitre à l'utilisateur, corrigé.
- Ebauche d'un guide d'utilisation rapide
- Corrections mineures diverses

Version de l'exécutable : 2.02g Samedi 11 Avril 2015
- Refonte de la gestion des écritures périodiques
- Corrections mineures diverses

Version de l'exécutable : 2.02f Jeudi 09 Avril 2015
- Ajout à la gestion des contacts d'un champ photo. Corrections de l'affichage de l'âge.
- Ajout de la recherche automatique des villes / régions sur les adresses (Contacts, Comptes, Fournisseurs) avec possibilité de situer automatiquement l'adresse dans Google Maps.
- Corrections du fichiers des trucs et astuces

Version de l'exécutable : 2.02e Mercredi 08 Avril 2015
- Ajout de la gestion des contacts
- Si les dates anniversaires sont renseigné, le ou les anniversaire(s) sont affichés sur l'écran d'accueil.
- Un clic sur l'alerte des anniversaires imprime (aperçu avant impression) la liste des anniversaires.
- Le contact concerné (ou le premier) est sélectionné.

Version de l'exécutable : 2.02d Mardi 07 Avril 2015
- Ajout des virements entre compte

Version de l'exécutable : 2.02c Lundi 06 Avril 2015
- Mise en production de l'import de fichier QIF (export de Money, Quicken Interchange Format).
- Corrections diverses mineures.

Version de l'exécutable : 2.02b Mardi 31 Mars 2015
- Fenêtre principale, section Reglages
Ajout d'un bouton pemettant de restaurer les tailles et positions des champs de saisies.
- Nouvelle fonction (en test) : import de fichier QIF (export de Money, Quicken Interchange Format)

Version de l'exécutable : 2.02a Lundi 30 Mars 2015
- Fenêtre de Gestion des écritures et Ecritures par compte
Refonte des traitement de récupérations des dépendances
(Compte, fournisseur, ventilation)
- Fenêtre de gestion des Répartitions analytiques
Ajout d'un bouton permettant de détacher la ligne en cours.
- Correction du fichier des types de documents (Création des types si le fichier
est vide, correction des liens si le type n'est pas renseigné).

Version de l'exécutable : 2.01x Samedi 28 Mars 2015
- Fenêtre de gestion des écritures périodiques
Ajout de la couleur dans les couleurs dans les tables
- Fenêtre de gestion des écritures / des écritures par compte
Correction du libellé colonne Document
Modification du texte des bulles d'accès aux gestions
- Fenêtre de création automatique des écritures périodiques arrivées à échéance
Correction de la procédure qui pouvait ne pas prendre en compte les montants
Ajout de la colonne Périodicité
- Import Gestion Privée V1
Correction des valeurs de périodicité
- Fenêtre de gestion des fournisseurs
Correction du traitement d'affichage du Grand-livre

Version de l'exécutable : 2.01w Vendredi 27 Mars 2015
- Corrections de la procédure d'affichage des couleurs dans les tables
(provoquait un plantage à l'ouverture des écritures périodiques à créer).

Version de l'exécutable : 2.01v Vendredi 27 Mars 2015
- Corrections de la procédure de restauration de sauvegarde.

Version de l'exécutable : 2.01u Jeudi 26 Mars 2015
- Refonte de la fenêtre sauvegarde / restauration.
-- Ajout d'un champ "Dossier" pour la sauvegarde via FTP
- Modification du moment du contrôle de version pour éviter la fausse info
"Pas de connexion internet"
Version de l'exécutable : 2.01t Jeudi 19 Mars 2015
- Implémentation de la fonction de restauration de sauvegarde.
- Correction des messages affichés lors du survol des boutons
- Ajout d'un bouton permettant d'annuler tous les rattachements des répartitions
- Alignement de champs un peu partout
Version de l'exécutable : 2.01s
- Mise en forme de la fenêtre de gestion des comptes
- Ajout du contrôle de la clé RIB
- Ajout de l'édition de RIB
- Ajout du contrôle de code postal + affichage département / région
- Corrections envoi sauvegarde par mail